Tahiti COM API: Tahiti COM API

  • Main Page
  • Classes
  • Files

Tahiti COM API

Introduction

This is documentation for Tahiti COM interface. It can be used for integration with other application or to directly control application.

How to start

Tahiti can be easily scripted using Visual Basic Script (.VBS) or any COM/.NET compatible language. Examples are usualy written in Visual Basic Script.

Simple example to display Tahiti version:

 set tahiti=CreateObject("LightComp.Tahiti")
 version = tahiti.version
 alert "Tahiti version: " & version
Generated on Thu Aug 27 12:37:14 2009 for Tahiti COM API


Tahiti COM API: Class List

  • Class List
  • Class Hierarchy
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
tcomIApplication | Main application object
tcomIAttribute | Collection of attributes
tcomIAttributes | Collection of attributes
tcomIComponent | Domain component
tcomIComponents | Collection of components
tcomIDocument | Document object
tcomIDocumentIOComponent | Shared Input/Output Component
tcomIDocumentManagerComponent | Document Manager Component
tcomIDocuments | Collection of documents
tcomIDomain | Domain
tcomIDomainConfiguration | Domain configuration
tcomIDomainListener | Domain state notification interface
tcomIDomains | Collection of domains
tcomIFrame | Frame
tcomILoginDialog | Login dialog object
tcomIObjectView | Object view
tcomIPackageOle | Tahiti OLE Package Interface
tcomIPage | Page object
tcomIPages | Collection of pages
tcomIProfile | Tahiti Profile
tcomIProfiles | Collection of profiles
tcomISharedComponent | Shared component
tcomISharedComponents | Collection of shared components
tcomISharedConfiguration | Shared configuration
tcomIViewObject | View object
tcomIViewObjectContainer | Object Container


Tahiti COM API: tcomIApplication Interface Reference

TahitiAutomation::tcomIApplication

tcomIApplication Interface Reference

Main application object. More...

List of all members.

Public Member Functions

HRESULT | MsgBox ([in] tcomIFrame *pParentFrame,[in] long type,[in] BSTR message,[in] BSTR detail,[out, retval] VARIANT *pvaItem)
Message Box.

Properties

BSTR | Version [get]
Return actual Tahiti version.
IDispatch | Domains [get]
Return collection of all available domains.
IDispatch | Components [get]
Return collection of all shared components.
IDispatch | Configuration [get]
Return shared configuration object.
IDispatch | LoginDialog [get]
Return login dialog.

Detailed Description

Main application object.

This object can be directly created as a COM object and provides access to the running Tahiti.

 set tahiti=CreateObject("LightComp.Tahiti")

Member Function Documentation

HRESULT MsgBox | ( | [in] tcomIFrame * | pParentFrame,
 |  | [in] long | type,
 |  | [in] BSTR | message,
 |  | [in] BSTR | detail,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Message Box.

Function display message box. This is simple modal dialog used to notify user about event or allows to ask question.

Parameters:
pParentFrame | Parent frame. Parametr can be null.
type Dialog type
  • 0 - Error - red icon
  • 1 - Information
  • 2 - Warning - yellow icon
  • 3 - Question with answer yes/no
  • 4 - Question with answer yes/no/cancel
  • 5 - Question with answer ok/cancel
message | Message to be display
detail | Optional string to display more information. This field is usually used to display technical details.
Return values:
pvaItem Return integer representing result
  • 0 - OK
  • 1 - Cancel
  • 2 - Yes
  • 3 - No

Property Documentation

IDispatch Components [get]

Return collection of all shared components.

It is possible to iterate over returned object and browse all shared components. Returned object is tcomISharedComponents.

Returns:
Return collection of components (tcomISharedComponents)

IDispatch Configuration [get]

Return shared configuration object.

Returns:
Return shared configuration. Object type is tcomISharedConfiguration

IDispatch Domains [get]

Return collection of all available domains.

It is possible to iterate over returned object and browse all domains. Returned object is tcomIDomains.

Returns:
Return collection of domains (tcomIDomains)

IDispatch LoginDialog [get]

Return login dialog.

Returns:
Return login dialog. Object type is tcomILoginDialog

BSTR Version [get]

Return actual Tahiti version.

Returns:
Returned value is string in format X.Y.Z., e.g. "5.0.1"


Tahiti COM API: tcomIAttribute Interface Reference

TahitiAutomation::tcomIAttribute

tcomIAttribute Interface Reference

Collection of attributes. More...

List of all members.

Properties

BSTR | Name [get]
Return attribute name.
BSTR | Value [get, set]
Return attibute value.

Detailed Description

Collection of attributes.

Object can be used to get specific attribute or to enumerate all attributes.

Property Documentation

BSTR Name [get]

Return attribute name.

Return values:
pbName Return attribute name.

BSTR Value [get, set]

Return attibute value.

Set attibute value.

Return values:
pbName Return attribute value.


Tahiti COM API: tcomIAttributes Interface Reference

TahitiAutomation::tcomIAttributes

tcomIAttributes Interface Reference

Collection of attributes. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for attribute objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return item.
HRESULT | AddAttribute ([in] BSTR name,[in] BSTR value,[out, retval] tcomIAttribute **ppAttribute)
Add attribute.
HRESULT | RemoveAttribute ([in] BSTR name)
Delete attribute.

Properties

VARIANT | Count [get]
Return number of attributes.

Detailed Description

Collection of attributes.

Object can be used to get specific attribute or to enumerate all attributes.

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for attribute objects.

Enumerated object are of type tcomIAttribute

Return values:
ppEnum Attribute enumerator

HRESULT AddAttribute | ( | [in] BSTR | name,
 |  | [in] BSTR | value,
 |  | [out, retval] tcomIAttribute ** | ppAttribute
 | ) |  |

Add attribute.

Add attribute to the collection

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return item.

Parameters:
pvaIndex Index (0...count-1) or name of the attribute. Index have to be integer, name is string.
Return values:
pvaItem Return attribute.

HRESULT RemoveAttribute ( [in] BSTR name )

Delete attribute.

Delete attribute from the collection

Property Documentation

VARIANT Count [get]

Return number of attributes.

Return values:
count Number of attributes


Tahiti COM API: tcomIComponent Interface Reference

TahitiAutomation::tcomIComponent

tcomIComponent Interface Reference

Domain component. More...

List of all members.

Public Member Functions

HRESULT | GetInterface ([out, retval] IDispatch **ppDisp)
Return component specific interface.

Properties

BSTR | Name [get]
Return component name.

Detailed Description

Domain component.

Object represents domain component.

Member Function Documentation

HRESULT GetInterface ( [out, retval] IDispatch ** ppDisp )

Return component specific interface.

Function return interface implementing component specific API. API of such interface depends on the component functionality. Check component specific documentation for more information.

Return values:
ppDisp IDispatch interface. Return NULL if such interface is not available.

Property Documentation

BSTR Name [get]

Return component name.

Return values:
pbName Return component name.


Tahiti COM API: tcomIComponents Interface Reference

TahitiAutomation::tcomIComponents

tcomIComponents Interface Reference

Collection of components. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for component objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return item.

Properties

VARIANT | Count [get]
Return number of available components.

Detailed Description

Collection of components.

Object can be used to get specific component or to enumerate all domain specific components.

Following code will find component "Scanner" in domain "test1":

 set tahiti=CreateObject("LightComp.Tahiti")
 set domains = tahiti.domains
 set domain = domains.item("test1")
 set components = domain.components
 set component = components.item("Scanner")

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for component objects.

Return values:
ppEnum Component enumerator

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return item.

Parameters:
pvaIndex Index (0...count-1) or name of the component. Index have to be integer, name is string.
Return values:
pvaItem Return component.

Property Documentation

VARIANT Count [get]

Return number of available components.

Return values:
count Number of components


Tahiti COM API: tcomIDocument Interface Reference

TahitiAutomation::tcomIDocument

tcomIDocument Interface Reference

Document object. More...

Inheritance diagram for tcomIDocument:

tcomIViewObjectContainer

List of all members.

Public Member Functions

HRESULT | AddPage ([in] BSTR filePath,[in] BSTR mimeType,[out, retval] tcomIPage **ppPage)
Add page to the document.
HRESULT | Commit ()
Commit document to the server.

Properties

IDispatch | Repository [get]
Return document repository.
IDispatch | Pages [get]
Return collection of pages.

Detailed Description

Document object.

Document stored in the repository.

Member Function Documentation

HRESULT AddPage | ( | [in] BSTR | filePath,
 |  | [in] BSTR | mimeType,
 |  | [out, retval] tcomIPage ** | ppPage
 | ) |  |

Add page to the document.

Add file to the document

HRESULT Commit ( )

Commit document to the server.

Commit document and all pages

Property Documentation

IDispatch Pages [get]

Return collection of pages.

It is possible to iterate over pages in the document. Returned object is tcomIPages.

Return values:
ppPages Return collection of pages (tcomIPages)

IDispatch Repository [get]

Return document repository.

Return values:
ppRepository Return repository. This object is type of tcomIDocumentManagerComponent


Tahiti COM API: tcomIDocumentIOComponent Interface Reference

TahitiAutomation::tcomIDocumentIOComponent

tcomIDocumentIOComponent Interface Reference

Shared Input/Output Component. More...

List of all members.

Public Member Functions

HRESULT CreateDocument ([in] long parentWnd,[out, retval] IDispatch **ppDocument)
Create new document.

Detailed Description

Shared Input/Output Component.

Component allows to import external data to the Tahiti. There is example how-to access this interface:

 set tahiti=CreateObject("LightComp.Tahiti")
 set comp = tahiti.components.item("DocumentIO")
 set docIO = comp.getInterface()

Member Function Documentation

HRESULT CreateDocument | ( | [in] long | parentWnd,
 |  | [out, retval] IDispatch ** | ppDocument
 | ) |  |

Create new document.

Parameters:
parentWnd Parent window handle (HWND)
Return values:
ppDocument Return newly created document. Return error if creation failed. Return E_ABORT if canceled.


Tahiti COM API: tcomIDocumentManagerComponent Interface Reference

TahitiAutomation::tcomIDocumentManagerComponent

tcomIDocumentManagerComponent Interface Reference

Document Manager Component. More...

List of all members.

Public Member Functions

HRESULT | CreateDocument ([in] BSTR documentType,[in] VARIANT_BOOL bEditAttributes,[out, retval] tcomIDocument **ppDocument)
Create new document.

Properties

IDispatch | Domain [get]
Return domain.
IDispatch | Documents [get]
Return collection of documents.

Detailed Description

Document Manager Component.

Component manage all documents, trees as well as provides access to the document repository.

Component name is: DocumentManager Simple example to access Document Manager

 set tahiti=CreateObject("LightComp.Tahiti")
 set domain=tahiti.domains.item("test.ept")
 set component = domain.components.item("DocumentManager")
 set docManager = component.GetInterface()

Member Function Documentation

HRESULT CreateDocument | ( | [in] BSTR | documentType,
 |  | [in] VARIANT_BOOL | bEditAttributes,
 |  | [out, retval] tcomIDocument ** | ppDocument
 | ) |  |

Create new document.

Function will create new document. It is possible to specify document type or create document without document type. In this case will be displayed dialog to select document type.

Parameters:
documentType | Type of new document. If this is empty string dialog to select document type will be displayed.
bEditAttributes | TRUE if dialog for editing attributes should be displayed. FALSE if attributes should not be edited.
Return values:
ppDocument Return newly created document. Return error if creation failed. Return E_ABORTED (0x80004004L) if canceled.

Property Documentation

IDispatch Documents [get]

Return collection of documents.

It is possible to iterate over returned object. Returned object is tcomIDocuments.

Return values:
pDocuments Return collection of documents (tcomIDocuments)

IDispatch Domain [get]

Return domain.

Return values:
ppDomain Return domain. This object is type of tcomIDomain


Tahiti COM API: tcomIDocuments Interface Reference

TahitiAutomation::tcomIDocuments

tcomIDocuments Interface Reference

Collection of documents. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for document objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return document.

Properties

VARIANT | Count [get]
Return number of available documents.

Detailed Description

Collection of documents.

Object can be used to get specific document or to enumerate all documents.

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for document objects.

Return values:
ppEnum Document enumerator

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return document.

Parameters:
pvaIndex Index (0...count-1) or id of the document. Index have to be integer, id is string.
Return values:
pvaItem Return document.

Property Documentation

VARIANT Count [get]

Return number of available documents.

Return values:
count Number of documents


Tahiti COM API: tcomIDomain Interface Reference

TahitiAutomation::tcomIDomain

tcomIDomain Interface Reference

Domain. More...

List of all members.

Public Member Functions

HRESULT | Deactivate ()
Deactivate domain.
HRESULT | Activate ([in] VARIANT *userName,[in] VARIANT *password,[in] VARIANT *mode,[out, retval] VARIANT *status)
Activate domain.
HRESULT | Connect ([out, retval] VARIANT_BOOL *status)

Properties

IDispatch | Configuration [get]
Domain configuration.
VARIANT | Status [get]
Return domain status.
IDispatch | Components [get]
Return collection of all domain specific components.
tcomIApplication | Application [get]
Application.
IDispatch | MainFrame [get]
Main domain frame.
VARIANT_BOOL | Connected [get]
check connected status

Detailed Description

Domain.

Domain object provides access to the domain specific data and also to the user interface of the running Tahiti. It is important to check state of domain before accessing UI functions.

Domain can be in 1 of 3 states:

  • 0 inactive - without UI - only some basic configuration is available
  • 1 activating - domain is about to activate. User should wait till domain become inactive or activated
  • 2 activated - domain is active with UI

Member Function Documentation

HRESULT Activate | ( | [in] VARIANT * | userName,
 |  | [in] VARIANT * | password,
 |  | [in] VARIANT * | mode,
 |  | [out, retval] VARIANT * | status
 | ) |  |

Activate domain.

Parameters:
userName | User name
password | Password
mode Connection mode
  • ONLINE domain will be connected to the server (authentication method can be passed as semicolon delimited optional parameter, example: ONLINE;external-token)
  • OFFLINE domain will be in offline mode (without network communication)
Return values:
status Return activation status
  • 0 inactive
  • 1 activating
  • 2 activated

HRESULT Connect ( [out, retval] VARIANT_BOOL * status )

Return values:
status true when domain is connected to server, false otherwise

HRESULT Deactivate ( )

Deactivate domain.

Deactivate domain and close all UI elements. Domain will be imidietly closed without asking user. Please be careful when to use this method. It better to let user save his work before deactivating domain. Look at the method Close in the tcomIFrame.

Domain can be later activated using method Activate.

Property Documentation

tcomIApplication Application [get]

Application.

This is main application object

IDispatch Components [get]

Return collection of all domain specific components.

It is possible to iterate over returned object. Returned object is tcomIComponents.

Return values:
pComponents Return collection of components (tcomIComponents)

IDispatch Configuration [get]

Domain configuration.

Returned object is type of tcomIDomainConfiguration

Returns:
Return domain configuration object.

VARIANT_BOOL Connected [get]

check connected status

Return values:
status true when domain is connected to server, false otherwise

IDispatch MainFrame [get]

Main domain frame.

Frame represents user interface for the domain.

Return values:
ppFrame Return main frame for this domain.

VARIANT Status [get]

Return domain status.

Read-only property

  • 0 inactive
  • 1 activating
  • 2 activated


Tahiti COM API: tcomIDomainConfiguration Interface Reference

TahitiAutomation::tcomIDomainConfiguration

tcomIDomainConfiguration Interface Reference

Domain configuration. More...

List of all members.

Public Member Functions

HRESULT | GetValue ([in] VARIANT *name,[out, retval] VARIANT *value)
Return value of the configuration item.
HRESULT | SetValue ([in] VARIANT *name,[in] VARIANT *value)
Set configuration.

Detailed Description

Domain configuration.

Object used to access domain configuration.

Member Function Documentation

HRESULT GetValue | ( | [in] VARIANT * | name,
 |  | [out, retval] VARIANT * | value
 | ) |  |

Return value of the configuration item.

Parameters:
name name of the item
Return values:
value Return value of the item. Return error if requested item doesn't exists.

HRESULT SetValue | ( | [in] VARIANT * | name,
 |  | [in] VARIANT * | value
 | ) |  |

Set configuration.

Parameters:
name | name of the item
value | value of the item


Tahiti COM API: tcomIDomainListener Interface Reference

TahitiAutomation::tcomIDomainListener

tcomIDomainListener Interface Reference

Domain state notification interface. More...

List of all members.

Public Member Functions

HRESULT | OnDomainCreated ([in] IDispatch *pDomain)
Domain was created.
HRESULT | OnDomainRemoved ([in] IDispatch *pDomain)
Domain was removed.
HRESULT | OnDomainStateChanged ([in] IDispatch *pDomain)
Domain state changed.
HRESULT | OnDomainConfigurationChanged ([in] IDispatch *pDomain)
Domain configuration was changed.

Detailed Description

Domain state notification interface.

This interface is used for notifications about domain state changes


Tahiti COM API: tcomIDomains Interface Reference

TahitiAutomation::tcomIDomains

tcomIDomains Interface Reference

Collection of domains. More...

List of all members.

Public Member Functions

HRESULT | Item ([in] VARIANT *index,[out, retval] VARIANT *pvaItem)
Return specific domain.
HRESULT | SelectDomain ([in] long parentWnd,[out, retval] VARIANT *pvaItem)
Select domain.
HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for domain objects.

Properties

VARIANT | Count [get]
Return number of domains.

Detailed Description

Collection of domains.

Object can be used to get specific domain or to enumerate all domains.

Following code will iterate all available domains:

 set tahiti=CreateObject("LightComp.Tahiti")
 set domains = tahiti.domains
 For Each domain In domains
  ' do something here
 Next

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for domain objects.

Enumerator is IEnumVARIANT. All enumerated objects have type of tcomIDomain.

Note:
This method is used in Visual Basic in "For Each .. In ... Next" statement.

HRESULT Item | ( | [in] VARIANT * | index,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return specific domain.

Return tcomIDomain object.

Parameters:
index This can be domain index (0...count-1) or domain name. Index have to be integer, domain name have to be string.
Return values:
pvaItem Return domain object if available (tcomIDomain). Return error if domain with given index does not exists or domain was not found.

HRESULT SelectDomain | ( | [in] long | parentWnd,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Select domain.

Function display domain selection dialog and allows to select domain. Return tcomIDomain object.

Return values:
pvaItem Return domain object if available (tcomIDomain). Return E_ABORTED (0x80004004L) if canceled.

Property Documentation

VARIANT Count [get]

Return number of domains.

Return number of all domains including active, inactive and hidden domains.

Returns:
Return number of domains.


Tahiti COM API: tcomIFrame Interface Reference

TahitiAutomation::tcomIFrame

tcomIFrame Interface Reference

Frame. More...

List of all members.

Public Member Functions

HRESULT | Activate ()
Activate frame.

Properties

VARIANT_BOOL | Visible [get, set]
Get visibility status.
tcomIProfiles | Profiles [get]
Return all available profiles.

Detailed Description

Frame.

Represents main frame for the domain.

Property Documentation

tcomIProfiles Profiles [get]

Return all available profiles.

It is possible to change profile using method activate in the tcomIProfile interface.

Return values:
ppProfiles Return available profiles in the domain.

VARIANT_BOOL Visible [get, set]

Get visibility status.

Show/Hide window.

Function return true if frame is visible.

Return values:
visible Return true if frame is visible. Return false if frame is not visible.
Parameters:
show True/False if frame should be visible.
Note:
Call Activate to set focus to the frame


Tahiti COM API: tcomILoginDialog Interface Reference

TahitiAutomation::tcomILoginDialog

tcomILoginDialog Interface Reference

Login dialog object. More...

List of all members.

Properties

VARIANT_BOOL | Visible [get, set]
Get visibility status.
BSTR | ActiveDomain [set]
Select domain.

Detailed Description

Login dialog object.

This object can be used to access login dialog.

Property Documentation

BSTR ActiveDomain [set]

Select domain.

Select given domain.

Parameters:
domain Name of the domain to be selected

VARIANT_BOOL Visible [get, set]

Get visibility status.

Show/Hide login dialog.

Function return true if dialog is visible.

Return values:
visible Return true if dialog is visible. Return false if dialog is not visible.
Parameters:
show True/False if dialog should be displayed.
Note:
When dialog is shown it will be automaticly activated (get focus)


Tahiti COM API: tcomIObjectView Interface Reference

TahitiAutomation::tcomIObjectView

tcomIObjectView Interface Reference

Object view. More...

List of all members.

Public Member Functions

HRESULT | Save ()
Save changes.
HRESULT | Close ()
Close view.

Properties

VARIANT_BOOL | Modified [get]
Check if view is modified.

Detailed Description

Object view.

View with displayed object

Member Function Documentation

HRESULT Close ( )

Close view.

Function will close current view.

Note:
This object is not longer valid after calling close operation.

HRESULT Save ( )

Save changes.

Function will save changes in the view

Property Documentation

VARIANT_BOOL Modified [get]

Check if view is modified.

Return values:
pModified Return true if view is modified. Return false if view is not modified.


Tahiti COM API: tcomIPackageOle Interface Reference

TahitiAutomation::tcomIPackageOle

tcomIPackageOle Interface Reference

Tahiti OLE Package Interface. More...

List of all members.

Properties

IDispatch | Document [get]
OLE object.
BSTR | Directory [get]
Path to the directory.
tcomIViewObject | Source [get]
Source object.
tcomIDomain | Domain [get]
Return domain.

Detailed Description

Tahiti OLE Package Interface.

This interface is used in package processing. Object is available in the running script for package type=2. This interface is available as object package.

Example to display message box:

 set domain=package.domain
 domain.application.MsgBox domain.MainFrame, 0, "Call from script", "Source directory :"&package.directory

Property Documentation

BSTR Directory [get]

Path to the directory.

This is directory where is extracted package and all its files.

IDispatch Document [get]

OLE object.

This is running OLE object.

  • For Microsoft Word this object represents Document.
  • For Microsoft Excel this object represents Workbook.

tcomIDomain Domain [get]

Return domain.

Return values:
ppDomain Return domain. This object is type of tcomIDomain

tcomIViewObject Source [get]

Source object.

Object in the Tahiti which is parent of this package. This is usualy page or final item.

Example how to get attributes of parent object:

 set attributes=package.source.parent.attributes
 For Each attribute In attributes
 ....
 Next


Tahiti COM API: tcomIPage Interface Reference

TahitiAutomation::tcomIPage

tcomIPage Interface Reference

Page object. More...

Inheritance diagram for tcomIPage:

tcomIViewObject

List of all members.

Public Member Functions

HRESULT | Open ([out, retval] IDispatch **ppOvi)
Open page.

Properties

VARIANT_BOOL | ValidData [get]
Return if page has valid data.

Detailed Description

Page object.

Page stored in the repository. Parent of this object is always document (tcomIDocument).

Member Function Documentation

HRESULT Open ( [out, retval] IDispatch ** ppOvi )

Open page.

Return values:
ppOvi Opened view, type of tcomIObjectView

Property Documentation

VARIANT_BOOL ValidData [get]

Return if page has valid data.

Return values:
pValidData Return true if page has valid data


Tahiti COM API: tcomIPages Interface Reference

TahitiAutomation::tcomIPages

tcomIPages Interface Reference

Collection of pages. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for page objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return page.

Properties

VARIANT | Count [get]
Return number of available pages.

Detailed Description

Collection of pages.

Object can be used to get specific page or to enumerate all pages.

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for page objects.

Return values:
ppEnum Page enumerator

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return page.

Parameters:
pvaIndex Index (0...count-1). Index have to be integer.
Return values:
pvaItem Return page.

Property Documentation

VARIANT Count [get]

Return number of available pages.

Return values:
count Number of pages


Tahiti COM API: tcomIProfile Interface Reference

TahitiAutomation::tcomIProfile

tcomIProfile Interface Reference

Tahiti Profile. More...

List of all members.

Public Member Functions

HRESULT | Activate ()
Activate this profile.
HRESULT | Restore ()
Restore this profile.

Properties

BSTR | Id [get]
Return profile id.
BSTR | Name [get]
Return profile name.
VARIANT_BOOL | Visible [get]
Return if profile is visible.

Detailed Description

Tahiti Profile.

Object represents profile.

Member Function Documentation

HRESULT Activate ( )

Activate this profile.

Profile will be activated with user's modifications.

HRESULT Restore ( )

Restore this profile.

Profile will be activated using original configuration (not modified by user).

Property Documentation

BSTR Id [get]

Return profile id.

Return values:
pbId Return profile id.

BSTR Name [get]

Return profile name.

Return values:
pbName Return profile name.

VARIANT_BOOL Visible [get]

Return if profile is visible.

Return values:
pbVisible Return profile visible status.


Tahiti COM API: tcomIProfiles Interface Reference

TahitiAutomation::tcomIProfiles

tcomIProfiles Interface Reference

Collection of profiles. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for profile objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return Profile.

Properties

VARIANT | Count [get]
Return number of available profiles.
IDispatch | Active [get]
Return active profile.

Detailed Description

Collection of profiles.

Object can be used to get specific profile or to enumerate all profiles.

Following code will find profile "tahitiDefault":

 set profile = frame.profiles.item("tahitiDefault")

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for profile objects.

Return values:
ppEnum Profile enumerator

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return Profile.

Parameters:
pvaIndex Index (0...count-1) or name of the profile. Index have to be integer, name is string.
Return values:
pvaItem Return profile.

Property Documentation

IDispatch Active [get]

Return active profile.

Returned interface is type of tcomIProfile

Return values:
pvaItem Return active profile.

VARIANT Count [get]

Return number of available profiles.

Return values:
count Number of profiles


Tahiti COM API: tcomISharedComponent Interface Reference

TahitiAutomation::tcomISharedComponent

tcomISharedComponent Interface Reference

Shared component. More...

List of all members.

Public Member Functions

HRESULT | GetInterface ([out, retval] IDispatch **ppDisp)
Return component specific interface.

Properties

BSTR | Name [get]
Return component name.

Detailed Description

Shared component.

Object represents shared component.

Member Function Documentation

HRESULT GetInterface ( [out, retval] IDispatch ** ppDisp )

Return component specific interface.

Function return interface implementing component specific API. API of such interface depends on the component functionality. Check component specific documentation for more information.

Return values:
ppDisp IDispatch interface. Return NULL if such interface is not available.

Property Documentation

BSTR Name [get]

Return component name.

Return values:
pbName Return component name.


Tahiti COM API: tcomISharedComponents Interface Reference

TahitiAutomation::tcomISharedComponents

tcomISharedComponents Interface Reference

Collection of shared components. More...

List of all members.

Public Member Functions

HRESULT | _NewEnum ([out, retval] IUnknown **ppEnum)
Enumerator for component objects.
HRESULT | Item ([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem)
Return item.

Properties

VARIANT | Count [get]
Return number of available components.

Detailed Description

Collection of shared components.

Object can be used to get specific component or to enumerate all shared components.

Following code will find component "DocumentIO":

 set tahiti=CreateObject("LightComp.Tahiti")
 set components = tahiti.components
 set component = components.item("DocumentIO")

Member Function Documentation

HRESULT _NewEnum ( [out, retval] IUnknown ** ppEnum )

Enumerator for component objects.

Return values:
ppEnum Component enumerator

HRESULT Item | ( | [in] VARIANT * | pvaIndex,
 |  | [out, retval] VARIANT * | pvaItem
 | ) |  |

Return item.

Parameters:
pvaIndex Index (0...count-1) or name of the component. Index have to be integer, name is string.
Return values:
pvaItem Return component.

Property Documentation

VARIANT Count [get]

Return number of available components.

Return values:
count Number of components


Tahiti COM API: tcomISharedConfiguration Interface Reference

TahitiAutomation::tcomISharedConfiguration

tcomISharedConfiguration Interface Reference

Shared configuration. More...

List of all members.

Public Member Functions

HRESULT GetValue ([in] VARIANT *name,[out, retval] VARIANT *value)
Return value of the configuration item.

Detailed Description

Shared configuration.

Object used to access shared configuration.

Member Function Documentation

HRESULT GetValue | ( | [in] VARIANT * | name,
 |  | [out, retval] VARIANT * | value
 | ) |  |

Return value of the configuration item.

Parameters:
name name of the item
Return values:
value Return value of the item. Return error if requested item doesn't exists.


Tahiti COM API: tcomIViewObject Interface Reference

TahitiAutomation::tcomIViewObject

tcomIViewObject Interface Reference

View object. More...

Inheritance diagram for tcomIViewObject:

tcomIPage

List of all members.

Properties

tcomIViewObjectContainer | Parent [get]
Return parent document.
BSTR | MimeType [get]
Return mime-type.

Detailed Description

View object.

Object which can be displayed

Property Documentation

BSTR MimeType [get]

Return mime-type.

Mime-type define type of the object and how-to display this object.

Return values:
pbName Name of mime-type.

tcomIViewObjectContainer Parent [get]

Return parent document.

Return values:
ppDocument Return parent document. This object is type of IDocument


Tahiti COM API: tcomIViewObjectContainer Interface Reference

TahitiAutomation::tcomIViewObjectContainer

tcomIViewObjectContainer Interface Reference

Object Container. More...

Inheritance diagram for tcomIViewObjectContainer:

tcomIDocument

List of all members.

Properties

tcomIAttributes Attributes [get]
Return attributes.

Detailed Description

Object Container.

Parent container of the object.

Property Documentation

tcomIAttributes Attributes [get]

Return attributes.

Return values:
ppAttributes Return attributes. This object is type of tcomIAttributes


Tahiti COM API: Hierarchical Index

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • tcomIApplication
  • tcomIAttribute
  • tcomIAttributes
  • tcomIComponent
  • tcomIComponents
  • tcomIDocumentIOComponent
  • tcomIDocumentManagerComponent
  • tcomIDocuments
  • tcomIDomain
  • tcomIDomainConfiguration
  • tcomIDomainListener
  • tcomIDomains
  • tcomIFrame
  • tcomILoginDialog
  • tcomIObjectView
  • tcomIPackageOle
  • tcomIPages
  • tcomIProfile
  • tcomIProfiles
  • tcomISharedComponent
  • tcomISharedComponents
  • tcomISharedConfiguration
  • tcomIViewObject
    • tcomIPage
  • tcomIViewObjectContainer
    • tcomIDocument


Tahiti COM API: Class Members

  • All
  • Functions
  • Properties
  • _
  • a
  • c
  • d
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • _NewEnum() : tcomIAttributes , tcomIDomains , tcomIProfiles , tcomISharedComponents , tcomIComponents , tcomIDocuments , tcomIPages

- a -

  • Activate() : tcomIProfile , tcomIFrame , tcomIDomain
  • Active : tcomIProfiles
  • ActiveDomain : tcomILoginDialog
  • AddAttribute() : tcomIAttributes
  • AddPage() : tcomIDocument
  • Application : tcomIDomain
  • Attributes : tcomIViewObjectContainer

- c -

  • Close() : tcomIObjectView
  • Commit() : tcomIDocument
  • Components : tcomIApplication , tcomIDomain
  • Configuration : tcomIDomain , tcomIApplication
  • Connect() : tcomIDomain
  • Connected : tcomIDomain
  • Count : tcomIDocuments , tcomIProfiles , tcomIAttributes , tcomISharedComponents , tcomIDomains , tcomIPages , tcomIComponents
  • CreateDocument() : tcomIDocumentManagerComponent , tcomIDocumentIOComponent

- d -

  • Deactivate() : tcomIDomain
  • Directory : tcomIPackageOle
  • Document : tcomIPackageOle
  • Documents : tcomIDocumentManagerComponent
  • Domain : tcomIDocumentManagerComponent , tcomIPackageOle
  • Domains : tcomIApplication

- g -

  • GetInterface() : tcomIComponent , tcomISharedComponent
  • GetValue() : tcomIDomainConfiguration , tcomISharedConfiguration

- i -

  • Id : tcomIProfile
  • Item() : tcomIDomains , tcomIProfiles , tcomISharedComponents , tcomIComponents , tcomIDocuments , tcomIPages , tcomIAttributes

- l -

  • LoginDialog : tcomIApplication

- m -

  • MainFrame : tcomIDomain
  • MimeType : tcomIViewObject
  • Modified : tcomIObjectView
  • MsgBox() : tcomIApplication

- n -

  • Name : tcomIAttribute , tcomIProfile , tcomISharedComponent , tcomIComponent

- o -

  • OnDomainConfigurationChanged() : tcomIDomainListener
  • OnDomainCreated() : tcomIDomainListener
  • OnDomainRemoved() : tcomIDomainListener
  • OnDomainStateChanged() : tcomIDomainListener
  • Open() : tcomIPage

- p -

  • Pages : tcomIDocument
  • Parent : tcomIViewObject
  • Profiles : tcomIFrame

- r -

  • RemoveAttribute() : tcomIAttributes
  • Repository : tcomIDocument
  • Restore() : tcomIProfile

- s -

  • Save() : tcomIObjectView
  • SelectDomain() : tcomIDomains
  • SetValue() : tcomIDomainConfiguration
  • Source : tcomIPackageOle
  • Status : tcomIDomain

- v -

  • ValidData : tcomIPage
  • Value : tcomIAttribute
  • Version : tcomIApplication
  • Visible : tcomIProfile , tcomIFrame , tcomILoginDialog


Tahiti COM API: File Index

  • File List

File List

Here is a list of all documented files with brief descriptions:
TahitiAutomation.idl [code]


Tahiti COM API: TahitiAutomation.idl Source File

  • File List

TahitiAutomation.idl

00001 import "ocidl.idl";
00002 import "oaidl.idl";
00003
00024 [ uuid(B8E9B776-B403-445a-BDA0-0BAA324A8F88),
00025   version(1.0),
00026   helpstring("LightComp Tahiti 5.0 Type Library") ]
00027 library TahitiAutomation
00028 {
00029         importlib("stdole2.tlb");
00030         // Forward declarations
00031         interface tcomIApplication;
00032         interface tcomIViewObject;
00033
00039 [
00040         object,
00041         uuid(5014B614-9FA6-4abd-897C-0A974E273991),
00042         dual,
00043         oleautomation,
00044         nonextensible,
00045         helpstring("tcomIAttribute Interface"),
00046         pointer_default(unique)
00047 ]
00048 interface tcomIAttribute : IDispatch {
00053     [propget, id(1), helpstring("return name")] HRESULT Name([out, retval] BSTR *pbName);
00054
00059     [propget, id(2), helpstring("return value")] HRESULT Value([out, retval] BSTR *pbValue);
00060
00065     [propput, id(2), helpstring("set value")] HRESULT Value([in] BSTR bValue);
00066 }
00067
00073 [
00074         object,
00075         uuid(81B32863-AB45-4065-B628-0AE82BF731BD),
00076         dual,
00077         oleautomation,
00078         nonextensible,
00079         helpstring("tcomIAttributes Interface"),
00080         pointer_default(unique)
00081 ]
00082 interface tcomIAttributes : IDispatch {
00087         [propget, id(1), helpstring("attributes count")] HRESULT Count([out, retval] VARIANT * count);
00088
00095         [id(0xfffffffc), helpstring("attribute enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00096
00102         [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00103
00109     [id(12), helpstring("Add attribute")] HRESULT AddAttribute([in] BSTR name, [in] BSTR value,[out, retval] tcomIAttribute **ppAttribute);
00110
00116     [id(13), helpstring("Remove attribute")] HRESULT RemoveAttribute([in] BSTR name);
00117
00118 }
00119
00125 [
00126         object,
00127         uuid(E72785F5-1F02-4a4b-8993-D8D6DBF43FC2),
00128         dual,
00129         oleautomation,
00130         nonextensible,
00131         helpstring("Object Container Interface"),
00132         pointer_default(unique)
00133 ]
00134 interface tcomIViewObjectContainer: IDispatch {
00140     [propget, id(3), helpstring("attributes")] HRESULT Attributes([out, retval] tcomIAttributes **ppAttributes);
00141 }
00142
00148 [
00149         object,
00150         uuid(855D8E7A-0E04-44cf-A482-E7F77E9529FC),
00151         dual,
00152         oleautomation,
00153         nonextensible,
00154         helpstring("Object View Interface"),
00155         pointer_default(unique)
00156 ]
00157 interface tcomIObjectView: IDispatch {
00163     [propget, id(1), helpstring("modified")] HRESULT Modified([out, retval] VARIANT_BOOL *pModified);
00164
00170     [id(2), helpstring("save changes")] HRESULT Save();
00171
00179     [id(3), helpstring("close view")] HRESULT Close();
00180 };
00181
00187 [
00188         object,
00189         uuid(9E05A4D5-920C-42c5-A972-E4807BD020A2),
00190         dual,
00191         oleautomation,
00192         nonextensible,
00193         helpstring("View Object Interface"),
00194         pointer_default(unique)
00195 ]
00196 interface tcomIViewObject: IDispatch {
00201     [propget, id(1), helpstring("document")] HRESULT Parent([out, retval] tcomIViewObjectContainer **ppDocument);
00202
00210     [propget, id(2), helpstring("return mime-type")] HRESULT MimeType([out, retval] BSTR *pbName);
00211 }
00212
00213
00220 [
00221         object,
00222         uuid(FBDA8954-AB84-417d-B1BC-966946864E02),
00223         dual,
00224         oleautomation,
00225         nonextensible,
00226         helpstring("Page Interface"),
00227         pointer_default(unique)
00228 ]
00229 interface tcomIPage: tcomIViewObject {
00235     [id(10), helpstring("return opened oobject")] HRESULT Open([out, retval] IDispatch **ppOvi);
00240     [propget, id(11), helpstring("valid page")] HRESULT ValidData([out, retval] VARIANT_BOOL *pValidData);
00241 }
00242
00249 [
00250         object,
00251         uuid(0E34B7EC-D0B1-4fb8-9B07-68A9649AE8C7),
00252         dual,
00253         oleautomation,
00254         nonextensible,
00255         helpstring("Pages Interface"),
00256         pointer_default(unique)
00257 ]
00258 interface tcomIPages: IDispatch {
00263         [propget, id(1), helpstring("page count")] HRESULT Count([out, retval] VARIANT * count);
00264
00269         [id(0xfffffffc), helpstring("document enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00270
00276         [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00277 };
00278
00284 [
00285         object,
00286         uuid(299AF503-A24F-4cb9-B376-22F4B36B117C),
00287         dual,
00288         oleautomation,
00289         nonextensible,
00290         helpstring("Document Interface"),
00291         pointer_default(unique)
00292 ]
00293 interface tcomIDocument: tcomIViewObjectContainer {
00298     [propget, id(10), helpstring("repository")] HRESULT Repository([out, retval] IDispatch **ppRepository);
00299
00305     [id(11), helpstring("Add page")] HRESULT AddPage([in] BSTR filePath, [in] BSTR mimeType,[out, retval] tcomIPage **ppPage);
00306
00313     [propget, id(12), helpstring("property documents")] HRESULT Pages([out, retval] IDispatch **ppPages);
00314
00320     [id(13), helpstring("Commit document")] HRESULT Commit();
00321 };
00322
00329 [
00330         object,
00331         uuid(5BDF7BBC-D2EA-4c5a-8E10-A9881AFF6698),
00332         dual,
00333         oleautomation,
00334         nonextensible,
00335         helpstring("tcomIDocuments Interface"),
00336         pointer_default(unique)
00337 ]
00338 interface tcomIDocuments : IDispatch {
00343         [propget, id(1), helpstring("documents count")] HRESULT Count([out, retval] VARIANT * count);
00344
00349         [id(0xfffffffc), helpstring("document enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00350
00356         [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00357 };
00358
00359
00360
00376 [
00377         object,
00378         uuid(37B73EB5-635F-4464-A9F3-FC9BE0D86590),
00379         dual,
00380         oleautomation,
00381         nonextensible,
00382         helpstring("Document Manager Interface"),
00383         pointer_default(unique)
00384 ]
00385 interface tcomIDocumentManagerComponent: IDispatch {
00390     [propget, id(1), helpstring("domain")] HRESULT Domain([out, retval] IDispatch **ppDomain);
00391
00405     [id(2), helpstring("Create Document")] HRESULT CreateDocument([in] BSTR documentType, [in] VARIANT_BOOL bEditAttributes, [out, retval] tcomIDocument **ppDocument);
00406
00413     [propget, id(3), helpstring("property documents")] HRESULT Documents([out, retval] IDispatch **pDocuments);
00414 };
00415
00416
00427 [
00428         object,
00429         uuid(81B864B5-5BB4-4ec4-B3E0-64265E170F70),
00430         dual,
00431         oleautomation,
00432         nonextensible,
00433         helpstring("Document Input/Output Component"),
00434         pointer_default(unique)
00435 ]
00436 interface tcomIDocumentIOComponent: IDispatch {
00443     [id(1), helpstring("Create Document")] HRESULT CreateDocument([in] long parentWnd, [out, retval] IDispatch **ppDocument);
00444 };
00445
00446
00452 [
00453         object,
00454         uuid(5FCA0B91-C5A0-45be-AD30-B797C61982C4),
00455         dual,
00456         oleautomation,
00457         nonextensible,
00458         helpstring("DomainConfiguration Interface"),
00459         pointer_default(unique)
00460 ]
00461 interface tcomIDomainConfiguration: IDispatch {
00462
00468     [id(1), helpstring("return value")] HRESULT GetValue([in] VARIANT *name, [out, retval] VARIANT *value);
00469
00475     [id(2), helpstring("set value")] HRESULT SetValue([in] VARIANT *name, [in] VARIANT *value);
00476 };
00477
00483 [
00484         object,
00485         uuid(908463AA-641B-4f23-8BA1-9077AAC8B7B6),
00486         dual,
00487         oleautomation,
00488         nonextensible,
00489         helpstring("tcomIComponent Interface"),
00490         pointer_default(unique)
00491 ]
00492 interface tcomIComponent : IDispatch {
00497     [propget, id(1), helpstring("return name")] HRESULT Name([out, retval] BSTR *pbName);
00498
00507     [id(2), helpstring("return component specific interface")] HRESULT GetInterface([out, retval] IDispatch **ppDisp);
00508 };
00509
00510
00524 [
00525         object,
00526         uuid(B2D2FD25-1D43-4034-AA6D-D67656F6CB55),
00527         dual,
00528         oleautomation,
00529         nonextensible,
00530         helpstring("tcomIComponents Interface"),
00531         pointer_default(unique)
00532 ]
00533 interface tcomIComponents : IDispatch {
00538         [propget, id(1), helpstring("properities componets count")] HRESULT Count([out, retval] VARIANT * count);
00539
00544         [id(0xfffffffc), helpstring("component enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00545
00551         [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00552 }
00553
00559 [
00560         object,
00561         uuid(554B86B2-5DBA-4584-9D52-CA59E3058E87),
00562         dual,
00563         oleautomation,
00564         nonextensible,
00565         helpstring("DomainConfiguration Interface"),
00566         pointer_default(unique)
00567 ]
00568 interface tcomISharedConfiguration: IDispatch {
00569
00575     [id(1), helpstring("return value")] HRESULT GetValue([in] VARIANT *name, [out, retval] VARIANT *value);
00576 };
00577
00583 [
00584         object,
00585         uuid(ED744F70-88EE-49ad-9C56-1ECB5E7C44AC),
00586         dual,
00587         oleautomation,
00588         nonextensible,
00589         helpstring("tcomISharedComponent Interface"),
00590         pointer_default(unique)
00591 ]
00592 interface tcomISharedComponent : IDispatch {
00597     [propget, id(1), helpstring("return name")] HRESULT Name([out, retval] BSTR *pbName);
00598
00607     [id(2), helpstring("return component specific interface")] HRESULT GetInterface([out, retval] IDispatch **ppDisp);
00608 };
00609
00622 [
00623         object,
00624         uuid(94907F27-6649-4a1b-B1F9-7C688070A992),
00625         dual,
00626         oleautomation,
00627         nonextensible,
00628         helpstring("tcomISharedComponents Interface"),
00629         pointer_default(unique)
00630 ]
00631 interface tcomISharedComponents : IDispatch {
00636     [propget, id(1), helpstring("properities componets count")] HRESULT Count([out, retval] VARIANT * count);
00637
00642     [id(0xfffffffc), helpstring("component enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00643
00649     [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00650 }
00651
00657 [
00658         object,
00659         uuid(08C6ECEB-DB14-43ce-876E-D7C1E49F63F6),
00660         dual,
00661         oleautomation,
00662         nonextensible,
00663         helpstring("tcomIProfile Interface"),
00664         pointer_default(unique)
00665 ]
00666 interface tcomIProfile : IDispatch {
00671     [propget, helpstring("return id")] HRESULT Id([out, retval] BSTR *pbId);
00672
00677     [propget, helpstring("return name")] HRESULT Name([out, retval] BSTR *pbName);
00678
00683     [propget, helpstring("return visible status")] HRESULT Visible([out, retval] VARIANT_BOOL *pbVisible);
00684
00690     [helpstring("Activate this profile")] HRESULT Activate();
00691
00698     [helpstring("Activate this profile")] HRESULT Restore();
00699 };
00700
00701
00713 [
00714         object,
00715         uuid(0EFB0DC7-664E-41b1-BAED-025818825FB4),
00716         dual,
00717         oleautomation,
00718         nonextensible,
00719         helpstring("tcomIProfiles Interface"),
00720         pointer_default(unique)
00721 ]
00722 interface tcomIProfiles : IDispatch {
00727     [propget, id(1), helpstring("profiles count")] HRESULT Count([out, retval] VARIANT * count);
00728
00733     [id(0xfffffffc), helpstring("profile enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00734
00740     [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *pvaIndex, [out, retval] VARIANT *pvaItem);
00741
00748     [propget, helpstring("return active profile")] HRESULT Active([out, retval] IDispatch **ppProfile);
00749 }
00750
00751
00757 [
00758         object,
00759         uuid(9D3A1F9F-8D6A-485c-B03D-1542F723B29D),
00760         dual,
00761         oleautomation,
00762         nonextensible,
00763         helpstring("tcomIFrame Interface"),
00764         pointer_default(unique)
00765 ]
00766 interface tcomIFrame: IDispatch {
00770     [id(1), helpstring("Activate frame")] HRESULT Activate();
00778     [propget, helpstring("return/set visibility of frame")] HRESULT Visible([out, retval] VARIANT_BOOL *visible);
00779
00785     [propput, helpstring("return/set visibility of login dialog")] HRESULT Visible([in] VARIANT_BOOL visible);
00786
00794     [propget, helpstring("return profiles")] HRESULT Profiles([out, retval] tcomIProfiles **ppProfiles);
00795 }
00796
00797
00811 [
00812         object,
00813         uuid(A1865BA9-C27D-4294-B26B-1887B93D0153),
00814         dual,
00815         oleautomation,
00816         nonextensible,
00817         helpstring("tcomIDomain Interface"),
00818         pointer_default(unique)
00819 ]
00820 interface tcomIDomain: IDispatch {
00827     [propget, id(1), helpstring("return configuration")] HRESULT Configuration([out, retval] IDispatch **pDispConfig);
00828
00837     [propget, id(2), helpstring("return status")] HRESULT Status([out, retval] VARIANT *pStatus);
00838
00848     [id(3), helpstring("Deactivate")] HRESULT Deactivate();
00849
00862     [id(4), helpstring("Activate domain")] HRESULT Activate([in] VARIANT *userName, [in] VARIANT *password, [in] VARIANT *mode, [out,retval] VARIANT *status);
00863
00870     [propget, id(5), helpstring("property components")] HRESULT Components([out, retval] IDispatch **pComponents);
00871
00877     [propget, id(6), helpstring("property components")] HRESULT Application([out, retval] tcomIApplication **pApplication);
00878
00885     [propget, id(7), helpstring("return main frame")] HRESULT MainFrame([out, retval] IDispatch **ppFrame);
00886
00892     [propget, id(8), helpstring("return connected status")] HRESULT Connected([out, retval] VARIANT_BOOL *status);
00893
00899     [id(9), helpstring("connect domain to server")] HRESULT Connect([out, retval] VARIANT_BOOL *status);
00900
00901
00902 };
00903
00917 [
00918         object,
00919         uuid(BA031138-2E75-4b50-AD4A-AE4EE3178149),
00920         dual,
00921         oleautomation,
00922         nonextensible,
00923         helpstring("tcomIDomains Interface"),
00924         pointer_default(unique)
00925 ]
00926 interface tcomIDomains : IDispatch {
00933         [propget, id(1), helpstring("properities domains count")] HRESULT Count([out, retval] VARIANT * count);
00934
00944         [id(2), helpstring("return item with given index")] HRESULT Item([in] VARIANT *index, [out, retval] VARIANT *pvaItem);
00945
00952         [id(3), helpstring("Select domain")] HRESULT SelectDomain([in] long parentWnd, [out, retval] VARIANT *pvaItem);
00953
00960         [id(0xfffffffc), helpstring("domain enumerator")] HRESULT _NewEnum([out, retval] IUnknown** ppEnum);
00961 };
00962
00968 [
00969         object,
00970         uuid(E93E0DF5-337A-4e99-BA37-B0D7F75D0C88),
00971         dual,
00972         oleautomation,
00973         nonextensible,
00974         helpstring("tcomILoginDialog Interface"),
00975         pointer_default(unique)
00976 ]
00977 interface tcomILoginDialog : IDispatch {
00985     [propget, helpstring("return/set visibility of login dialog")] HRESULT Visible([out, retval] VARIANT_BOOL *visible);
00986
00992     [propput, helpstring("return/set visibility of login dialog")] HRESULT Visible([in] VARIANT_BOOL visible);
00993
01000     [propput, helpstring("select domain")] HRESULT ActiveDomain([in] BSTR domainName);
01001 }
01002
01016 [
01017         object,
01018         uuid(3988A18E-60BC-4875-90E4-CD16CFD9BA0D),
01019         dual,
01020         nonextensible,
01021         helpstring("tcomIPackageOle Interface"),
01022         pointer_default(unique)
01023 ]
01024 interface tcomIPackageOle : IDispatch{
01032     [propget, id(1), helpstring("property document")] HRESULT Document([out, retval] IDispatch** pVal);
01033
01039     [propget, id(2), helpstring("property directory")] HRESULT Directory([out, retval] BSTR* pVal);
01040
01054     [propget, id(3), helpstring("property source")] HRESULT Source([out, retval] tcomIViewObject** pVal);
01055
01060     [propget, id(4), helpstring("domain")] HRESULT Domain([out, retval] tcomIDomain **ppDomain);
01061
01062 };
01063
01064
01065
01073 [
01074         object,
01075         uuid(A7003131-C75E-4523-9772-A4F1D44DBE65),
01076         dual,
01077         oleautomation,
01078         nonextensible,
01079         helpstring("tcomIApplication Interface"),
01080         pointer_default(unique)
01081 ]
01082 interface tcomIApplication : IDispatch {
01087         [propget, id(1), helpstring("method GetVersion")] HRESULT Version([out, retval] BSTR* version);
01088
01095         [propget, id(2), helpstring("property domains")] HRESULT Domains([out, retval] IDispatch **pDomains);
01096
01104         [propget, id(3), helpstring("property components")] HRESULT Components([out, retval] IDispatch **ppComponents);
01105
01111         [propget, id(4), helpstring("property configuration")] HRESULT Configuration([out, retval] IDispatch **ppConfiguration);
01112
01113
01119         [propget, id(5), helpstring("property login dialog")] HRESULT LoginDialog([out, retval] IDispatch **ppLoginDialog);
01120
01143         [id(6), helpstring("Message Box")] HRESULT MsgBox([in] tcomIFrame *pParentFrame,
01144                         [in] long type, [in] BSTR message, [in] BSTR detail, [out, retval] VARIANT *pvaItem);
01145
01146 };
01147
01148
01155 [
01156         uuid(A8B796CA-6D50-4c7e-9C84-18984CAE5C87),
01157         helpstring("tcomIDomainListener dispinterface")
01158 ]
01159 dispinterface tcomIDomainListener {
01160 properties:
01161 methods:
01165         [id(100)] HRESULT OnDomainCreated([in] IDispatch *pDomain);
01166
01170         [id(101)] HRESULT OnDomainRemoved([in] IDispatch *pDomain);
01171
01175         [id(102)] HRESULT OnDomainStateChanged([in] IDispatch *pDomain);
01176
01180         [id(103)] HRESULT OnDomainConfigurationChanged([in] IDispatch *pDomain);
01181 };
01182
01183
01184 [
01185         uuid(7860A07D-B087-4AF7-ADF5-88403ADA0388),
01186         helpstring("TahitiAutom_Application Class")
01187 ]
01188 coclass Application
01189 {
01190         [default] interface tcomIApplication;
01191         [default,source] dispinterface tcomIDomainListener;
01192 };
01193
01194 };


Tahiti COM API: Member List

tcomIAttribute Member List

This is the complete list of members for tcomIAttribute, including all inherited members.

Name | tcomIAttribute
Value | tcomIAttribute


Tahiti COM API: Member List

tcomIAttributes Member List

This is the complete list of members for tcomIAttributes, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIAttributes
AddAttribute([in] BSTR name,[in] BSTR value,[out, retval] tcomIAttribute **ppAttribute) | tcomIAttributes
Count | tcomIAttributes
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomIAttributes
RemoveAttribute([in] BSTR name) | tcomIAttributes


Tahiti COM API: Member List

tcomIViewObjectContainer Member List

This is the complete list of members for tcomIViewObjectContainer, including all inherited members.

Attributes tcomIViewObjectContainer


Tahiti COM API: Member List

tcomIObjectView Member List

This is the complete list of members for tcomIObjectView, including all inherited members.

Close() | tcomIObjectView
Modified | tcomIObjectView
Save() | tcomIObjectView


Tahiti COM API: Member List

tcomIViewObject Member List

This is the complete list of members for tcomIViewObject, including all inherited members.

MimeType | tcomIViewObject
Parent | tcomIViewObject


Tahiti COM API: Member List

tcomIPage Member List

This is the complete list of members for tcomIPage, including all inherited members.

MimeType | tcomIViewObject
Open([out, retval] IDispatch **ppOvi) | tcomIPage
Parent | tcomIViewObject
ValidData | tcomIPage


Tahiti COM API: Member List

tcomIPages Member List

This is the complete list of members for tcomIPages, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIPages
Count | tcomIPages
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomIPages


Tahiti COM API: Member List

tcomIDocument Member List

This is the complete list of members for tcomIDocument, including all inherited members.

AddPage([in] BSTR filePath,[in] BSTR mimeType,[out, retval] tcomIPage **ppPage) | tcomIDocument
Attributes | tcomIViewObjectContainer
Commit() | tcomIDocument
Pages | tcomIDocument
Repository | tcomIDocument


Tahiti COM API: Member List

tcomIDocuments Member List

This is the complete list of members for tcomIDocuments, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIDocuments
Count | tcomIDocuments
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomIDocuments


Tahiti COM API: Member List

tcomIDocumentManagerComponent Member List

This is the complete list of members for tcomIDocumentManagerComponent, including all inherited members.

CreateDocument([in] BSTR documentType,[in] VARIANT_BOOL bEditAttributes,[out, retval] tcomIDocument **ppDocument) | tcomIDocumentManagerComponent
Documents | tcomIDocumentManagerComponent
Domain | tcomIDocumentManagerComponent


Tahiti COM API: Member List

tcomIDocumentIOComponent Member List

This is the complete list of members for tcomIDocumentIOComponent, including all inherited members.

CreateDocument([in] long parentWnd,[out, retval] IDispatch **ppDocument) tcomIDocumentIOComponent


Tahiti COM API: Member List

tcomIDomainConfiguration Member List

This is the complete list of members for tcomIDomainConfiguration, including all inherited members.

GetValue([in] VARIANT *name,[out, retval] VARIANT *value) | tcomIDomainConfiguration
SetValue([in] VARIANT *name,[in] VARIANT *value) | tcomIDomainConfiguration


Tahiti COM API: Member List

tcomIComponent Member List

This is the complete list of members for tcomIComponent, including all inherited members.

GetInterface([out, retval] IDispatch **ppDisp) | tcomIComponent
Name | tcomIComponent


Tahiti COM API: Member List

tcomIComponents Member List

This is the complete list of members for tcomIComponents, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIComponents
Count | tcomIComponents
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomIComponents


Tahiti COM API: Member List

tcomISharedConfiguration Member List

This is the complete list of members for tcomISharedConfiguration, including all inherited members.

GetValue([in] VARIANT *name,[out, retval] VARIANT *value) tcomISharedConfiguration


Tahiti COM API: Member List

tcomISharedComponent Member List

This is the complete list of members for tcomISharedComponent, including all inherited members.

GetInterface([out, retval] IDispatch **ppDisp) | tcomISharedComponent
Name | tcomISharedComponent


Tahiti COM API: Member List

tcomISharedComponents Member List

This is the complete list of members for tcomISharedComponents, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomISharedComponents
Count | tcomISharedComponents
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomISharedComponents


Tahiti COM API: Member List

tcomIProfile Member List

This is the complete list of members for tcomIProfile, including all inherited members.

Activate() | tcomIProfile
Id | tcomIProfile
Name | tcomIProfile
Restore() | tcomIProfile
Visible | tcomIProfile


Tahiti COM API: Member List

tcomIProfiles Member List

This is the complete list of members for tcomIProfiles, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIProfiles
Active | tcomIProfiles
Count | tcomIProfiles
Item([in] VARIANT *pvaIndex,[out, retval] VARIANT *pvaItem) | tcomIProfiles


Tahiti COM API: Member List

tcomIFrame Member List

This is the complete list of members for tcomIFrame, including all inherited members.

Activate() | tcomIFrame
Profiles | tcomIFrame
Visible | tcomIFrame


Tahiti COM API: Member List

tcomIDomain Member List

This is the complete list of members for tcomIDomain, including all inherited members.

Activate([in] VARIANT *userName,[in] VARIANT *password,[in] VARIANT *mode,[out, retval] VARIANT *status) | tcomIDomain
Application | tcomIDomain
Components | tcomIDomain
Configuration | tcomIDomain
Connect([out, retval] VARIANT_BOOL *status) | tcomIDomain
Connected | tcomIDomain
Deactivate() | tcomIDomain
MainFrame | tcomIDomain
Status | tcomIDomain


Tahiti COM API: Member List

tcomIDomains Member List

This is the complete list of members for tcomIDomains, including all inherited members.

_NewEnum([out, retval] IUnknown **ppEnum) | tcomIDomains
Count | tcomIDomains
Item([in] VARIANT *index,[out, retval] VARIANT *pvaItem) | tcomIDomains
SelectDomain([in] long parentWnd,[out, retval] VARIANT *pvaItem) | tcomIDomains


Tahiti COM API: Member List

tcomILoginDialog Member List

This is the complete list of members for tcomILoginDialog, including all inherited members.

ActiveDomain | tcomILoginDialog
Visible | tcomILoginDialog


Tahiti COM API: Member List

tcomIPackageOle Member List

This is the complete list of members for tcomIPackageOle, including all inherited members.

Directory | tcomIPackageOle
Document | tcomIPackageOle
Domain | tcomIPackageOle
Source | tcomIPackageOle


Tahiti COM API: Member List

tcomIApplication Member List

This is the complete list of members for tcomIApplication, including all inherited members.

Components | tcomIApplication
Configuration | tcomIApplication
Domains | tcomIApplication
LoginDialog | tcomIApplication
MsgBox([in] tcomIFrame *pParentFrame,[in] long type,[in] BSTR message,[in] BSTR detail,[out, retval] VARIANT *pvaItem) | tcomIApplication
Version | tcomIApplication


Tahiti COM API: Member List

tcomIDomainListener Member List

This is the complete list of members for tcomIDomainListener, including all inherited members.

OnDomainConfigurationChanged([in] IDispatch *pDomain) | tcomIDomainListener
OnDomainCreated([in] IDispatch *pDomain) | tcomIDomainListener
OnDomainRemoved([in] IDispatch *pDomain) | tcomIDomainListener
OnDomainStateChanged([in] IDispatch *pDomain) | tcomIDomainListener


Tahiti COM API: Alphabetical List

Class Index

T

T
tcomIDocument (TahitiAutomation) tcomIDomainListener (TahitiAutomation) tcomIPackageOle (TahitiAutomation) tcomISharedComponent (TahitiAutomation)
tcomIApplication (TahitiAutomation) | tcomIDocumentIOComponent (TahitiAutomation) | tcomIDomains (TahitiAutomation) | tcomIPage (TahitiAutomation) | tcomISharedComponents (TahitiAutomation)
tcomIAttribute (TahitiAutomation) | tcomIDocumentManagerComponent (TahitiAutomation) | tcomIFrame (TahitiAutomation) | tcomIPages (TahitiAutomation) | tcomISharedConfiguration (TahitiAutomation)
tcomIAttributes (TahitiAutomation) | tcomIDocuments (TahitiAutomation) | tcomILoginDialog (TahitiAutomation) | tcomIProfile (TahitiAutomation) | tcomIViewObject (TahitiAutomation)
tcomIComponent (TahitiAutomation) | tcomIDomain (TahitiAutomation) | tcomIObjectView (TahitiAutomation) | tcomIProfiles (TahitiAutomation) | tcomIViewObjectContainer (TahitiAutomation)
tcomIComponents (TahitiAutomation) | tcomIDomainConfiguration (TahitiAutomation)

T


Tahiti COM API: Class Members - Functions

  • All
  • Functions
  • Properties
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • o
  • r
  • s

- _ -

  • _NewEnum() : tcomIAttributes , tcomIDomains , tcomIProfiles , tcomISharedComponents , tcomIComponents , tcomIDocuments , tcomIPages

- a -

  • Activate() : tcomIProfile , tcomIFrame , tcomIDomain
  • AddAttribute() : tcomIAttributes
  • AddPage() : tcomIDocument

- c -

  • Close() : tcomIObjectView
  • Commit() : tcomIDocument
  • Connect() : tcomIDomain
  • CreateDocument() : tcomIDocumentManagerComponent , tcomIDocumentIOComponent

- d -

  • Deactivate() : tcomIDomain

- g -

  • GetInterface() : tcomIComponent , tcomISharedComponent
  • GetValue() : tcomIDomainConfiguration , tcomISharedConfiguration

- i -

  • Item() : tcomIAttributes , tcomIDomains , tcomIProfiles , tcomISharedComponents , tcomIComponents , tcomIDocuments , tcomIPages

- m -

  • MsgBox() : tcomIApplication

- o -

  • OnDomainConfigurationChanged() : tcomIDomainListener
  • OnDomainCreated() : tcomIDomainListener
  • OnDomainRemoved() : tcomIDomainListener
  • OnDomainStateChanged() : tcomIDomainListener
  • Open() : tcomIPage

- r -

  • RemoveAttribute() : tcomIAttributes
  • Restore() : tcomIProfile

- s -

  • Save() : tcomIObjectView
  • SelectDomain() : tcomIDomains
  • SetValue() : tcomIDomainConfiguration


Tahiti COM API: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • v

- a -

  • Active : tcomIProfiles
  • ActiveDomain : tcomILoginDialog
  • Application : tcomIDomain
  • Attributes : tcomIViewObjectContainer

- c -

  • Components : tcomIDomain , tcomIApplication
  • Configuration : tcomIApplication , tcomIDomain
  • Connected : tcomIDomain
  • Count : tcomIDocuments , tcomIPages , tcomIAttributes , tcomIProfiles , tcomIDomains , tcomISharedComponents , tcomIComponents

- d -

  • Directory : tcomIPackageOle
  • Document : tcomIPackageOle
  • Documents : tcomIDocumentManagerComponent
  • Domain : tcomIDocumentManagerComponent , tcomIPackageOle
  • Domains : tcomIApplication

- i -

  • Id : tcomIProfile

- l -

  • LoginDialog : tcomIApplication

- m -

  • MainFrame : tcomIDomain
  • MimeType : tcomIViewObject
  • Modified : tcomIObjectView

- n -

  • Name : tcomIAttribute , tcomIProfile , tcomISharedComponent , tcomIComponent

- p -

  • Pages : tcomIDocument
  • Parent : tcomIViewObject
  • Profiles : tcomIFrame

- r -

  • Repository : tcomIDocument

- s -

  • Source : tcomIPackageOle
  • Status : tcomIDomain

- v -

  • ValidData : tcomIPage
  • Value : tcomIAttribute
  • Version : tcomIApplication
  • Visible : tcomIProfile , tcomIFrame , tcomILoginDialog